Como podemos constatar nesse link (clique aqui para acessa-lo) foi o último release da família 5.3.X, atualizações de segurança serão provisionadas somente até Julho de 2014 (mês em que estamos escrevendo esse artigo).

Por conta disso a Hosting Machine está providenciando servidores com o PHP 5.4.X. Em alguns casos estamos migrando clientes de servidores compartilhados com o PHP 5.3.X para nossos servidores com o PHP 5.4.X. Nesses casos clientes que utilizam o Joomla 1.5.X estão visualizando alguns erros de incompatibilidade com o PHP 5.4.X como:

“Strict Standards: Declaration of JParameter::loadSetupFile() should be compatible with that of JRegistry::loadSetupFile()”

ou

“Strict Standards: Non-static method JLoader::import() should not be called statically in”

Corrigir esses erros é muito fácil, basta acessar o administrador da instalação Joomla e em “Global Configuration” clicar em “Server” e então selecionar a opção “none” (ou “nenhum”) para “Error reporting”.

De qualquer forma devemos alerta-los de que o uso de scripts desatualizados como o Joomla 1.5.X é um enorme risco de segurança para sua hospedagem além dos transtornos causados por incompatibilidade com novas versões do PHP.

Sobre o autor