Ao realizarmos o procedimento de migração de uma conta para outro servidor, ela carrega as configurações do servidor anterior, que lá funcionavam normalmente, mas em algumas oportunidades, haverá necessidade de ajustes, pois o novo ambiente poderá ter algumas características diferentes.

Isso se deve a uma ocorrência bastante comum, que é a atualização de componentes, algo que fazemos todos os dias para aplicativos do nosso computador, smartphone, entre outros e os servidores de hospedagem não teriam como fugir à essa regra.

No caso, o principal item que precisa ser observado, é com relação a versão do PHP. Nos novos servidores, a versão vem configurada como 5.4, pois esta é a versão mais antiga ainda suportada pelo desenvolvedor. Porém, muitos sites ainda utilizam a versão 5.3 ou anterior e nós também continuamos as oferecendo.

Para esta verificação e alteração, basta acessar o painel de controle da sua hospedagem, procurar a opção “Seletor PHP Versão” e lá você poderá alterar a versão utilizada na sua hospedagem.

Dito isso, um erro comum que ocorre, também relacionado ao PHP, é o site passar a exibir o erro 500. Este erro ocorre quando:

1) Você estiver utilizando um comando chamado SetEnv no .htaccess (a versão do apache que usamos não aceita esse comando, mas aceita o comando que indicamos em nosso blog: https://faq.hostmach.com.br/alterando-diretivas-do-php-em-sua-hospedagem-cpanel/ );
2) Sua hospedagem tiver arquivos ou diretórios com permissão 777. Neste caso, efetue os ajustes necessários, de modo que as pastas estejam com permissão 755 e os arquivos estejam com permissão 644;
3) Ou ainda, caso você utilizar uma diretiva de PHP descontinuada no php 5.4 (como register_globals, por exemplo).

Nestes casos, a solução é você mudar a linha no .htaccess para o que indicamos (“suPHP_ConfigPath”) na postagem em nosso blog. Segue novamente o link: https://faq.hostmach.com.br/alterando-diretivas-do-php-em-sua-hospedagem-cpanel/

Agora, se você precisar muito mesmo do register_globals, então altere a versão do PHP para o 5.3, na opção “Seletor PHP Versão”, disponível no painel de controle da sua hospedagem.

Outra questão é sobre scripts desatualizados. As versões mais recentes do PHP requerem que o script também esteja em uma versão recente, para não causar erros. Se houver um script desatualizado na sua hospedagem, nosso sistema irá te avisar, através de uma mensagem postada no seu cadastro, que poderá ser conferida em www.hostmach.com.br/cadastro

Em caso de qualquer dúvida, nosso suporte está sempre disponível para ajudá-lo, bastando abrir seu chamado em www.hostmach.com.br/suporte

Sobre o autor